• The moderator of this forum is Austin.
  • Welcome to Smogon! Take a moment to read the Introduction to Smogon for a run-down on everything Smogon, and make sure you take some time to read the global rules.

Programming Showdex - An Auto-Updating Damage Calculator Built into Showdown!

feel bad for making a 1-liner here but I don't know what I'm talking about so lol. smogon sets just don't import into the calc for me, they have a little loading animation.

edit: this is what I'm referring too
View attachment 466248
I reset to default settings and reinstalled as well and still have this issue. Any solutions?
No worries, your screenshot is helpful enough!

Seems that the sets started downloading, but never finished. Usually should finish downloading within a few seconds at most, so something's wrong if it's hanging like that. There shouldn't be anything wrong with your settings if the loading animation appears (would be more concerning if it didn't).

If you could provide me with the following info, that would help me out a lot!
  • OS (Windows, macOS, Ubuntu, Android on a Samsung Smart Fridge, etc.)
  • Browser (Chrome, Firefox, Opera, etc.)
  • Showdex version (e.g., v1.0.6)
  • Format (though it looks like gen81v1 based on your 3 Pokémon)
Lastly, does it ever stop loading? (Would be fair to say no if it's still loading after 30 seconds.)

Thanks!
 

Togkey

is a Forum Moderatoris a Community Contributoris a Top Tiering Contributoris a Contributor to Smogon
Moderator
No worries, your screenshot is helpful enough!

Seems that the sets started downloading, but never finished. Usually should finish downloading within a few seconds at most, so something's wrong if it's hanging like that. There shouldn't be anything wrong with your settings if the loading animation appears (would be more concerning if it didn't).

If you could provide me with the following info, that would help me out a lot!
  • OS (Windows, macOS, Ubuntu, Android on a Samsung Smart Fridge, etc.)
  • Browser (Chrome, Firefox, Opera, etc.)
  • Showdex version (e.g., v1.0.6)
  • Format (though it looks like gen81v1 based on your 3 Pokémon)
Lastly, does it ever stop loading? (Would be fair to say no if it's still loading after 30 seconds.)

Thanks!
Edit:
Windows
Chrome
1.0.6
All formats
Never loads period
 
Last edited:
Hello, this is probably known, but wanted to point it out anyway.

Showdex simply seems to crash whenever a gen 9 battle starts:

1668830637206.png
 

Sabelette

"What does 7Used mean"
is a Community Contributor
Awesome calculator but just wanted to mention a tiny issue, some stats for gen 1 mons show as 1 point too high! In gen 1 stat caps are 1 point lower because of how stat exp works (think it's the same in gen 2 as well). Here's an example with Snorlax, for some reason HP and SPC are correct and the others aren't.

1670015626731.png

1670015560967.png
 
Edit:
Windows
Chrome
1.0.6
All formats
Never loads period
Hmm damn, everything seems pretty standard.

Last thing, could you go into your Chrome extensions page (type in chrome://extensions into your URL bar), click on Details for Showdex, then verify that https://pkmn.github.io/* is enabled under Site access (or Automatically allow access on the following sites is enabled like in the screenshot below)?

SCR-20221205-pt2.png


Thanks! :o
 
Awesome calculator but just wanted to mention a tiny issue, some stats for gen 1 mons show as 1 point too high! In gen 1 stat caps are 1 point lower because of how stat exp works (think it's the same in gen 2 as well). Here's an example with Snorlax, for some reason HP and SPC are correct and the others aren't.

View attachment 470315
View attachment 470314
Good catch! Might be a rounding error on my end since I know legacy gens use some weird rounding technique. I'll double check. Thanks!! :)
 
I know the extension works for other people, but when I try to use it I get the issue visible below.
Any ideas what the problem might be?
View attachment 468340
Could you let me know what gen and format this battle is in? Additionally, your OS (Windows/macOS/Linux/etc.) and Browser would be helpful info too!

Definitely strange that the row of Pokémon is missing (even if no Pokémon are loaded, there should be a pixel dot icon at the very least).
 
Hmmmmmmmmmmmmmmmmm... the rabbit hole continues... :o

When you're in a battle with the Calcdex open and it's doing the loading thingy, can you right-click anywhere on the page, click Inspect (or hit F12), go to the Console tab at the top, then anywhere in the logs, right-click, Save as..., then send me the resulting *.log file? (Don't think there's any personal identifiable information in there, but if you'd like, feel free to PM me as well.)

SCR-20221205-u38.png


You may not see as many logs like you see in the screenshot above, but hopefully it'll help me narrow down the problem.

(Hoping that it pooped some error out onto the console since the Calcdex visually shows that it's still loading. Worse case, nothing's there, but we'll cross that bridge then.)

Thanks again lolol.
 
Could you let me know what gen and format this battle is in? Additionally, your OS (Windows/macOS/Linux/etc.) and Browser would be helpful info too!

Definitely strange that the row of Pokémon is missing (even if no Pokémon are loaded, there should be a pixel dot icon at the very least).
I get the problem for every gen and format but I believe the image shown is from gen 8 randbats.
 

Togkey

is a Forum Moderatoris a Community Contributoris a Top Tiering Contributoris a Contributor to Smogon
Moderator
Hmmmmmmmmmmmmmmmmm... the rabbit hole continues... :o

When you're in a battle with the Calcdex open and it's doing the loading thingy, can you right-click anywhere on the page, click Inspect (or hit F12), go to the Console tab at the top, then anywhere in the logs, right-click, Save as..., then send me the resulting *.log file? (Don't think there's any personal identifiable information in there, but if you'd like, feel free to PM me as well.)

View attachment 471499

You may not see as many logs like you see in the screenshot above, but hopefully it'll help me narrow down the problem.

(Hoping that it pooped some error out onto the console since the Calcdex visually shows that it's still loading. Worse case, nothing's there, but we'll cross that bridge then.)

Thanks again lolol.
currently I get the error with the QR code on it so I don't even get the loading error
 

Users Who Are Viewing This Thread (Users: 1, Guests: 0)

Top